Message Board

 
 

2018 Western Meet
[clock1]

2018 Eastern Meet
[clock2]
 
 
Home  | Join  | Merchandise  | West Meet | East Meet | Monte photos
Meet Photos | Tech  | Museum  | Parts  | Registry  | Links  | Officers
 
 

Jump to content


Photo

Gas Gauge Not Working


  • Please log in to reply
23 replies to this topic

#21 Shnalla

Shnalla

    Keep the Rock rolling !

  • Members

  • 249 posts
  • LocationLyon, France.
  • Legal Name:Romain Scheibert
  • Occupation:Art Director

Posted 13 September 2017 - 01:26 AM

I assume you just dropped it right into the tank with no fiddling around worked first time?

 

Yes, it worked first time.
When I ordered it I just checked for the right part (without return line in my case) and I was fine.


Romain

Posted Image
Work Hard, Make Money, Fix your Car !

#22 NWmonte71

NWmonte71

    Advanced Member

  • Members

  • 87 posts
  • LocationPoulsbo, WA
  • Legal Name:Chris Harris
  • Occupation:DON

Posted 13 September 2017 - 07:54 PM

I see 3 different brands offered on Rock Auto, which one did you guys choose? By the way, my sending unit does not have a second return line tube, I will need the single line unit.


sml_gallery_5838_288_247210.jpg1971 Monte Carlo, #'s matching 350cid with TH350, Factory "Lime Green" with original "Antique White" painted top.


#23 Shnalla

Shnalla

    Keep the Rock rolling !

  • Members

  • 249 posts
  • LocationLyon, France.
  • Legal Name:Romain Scheibert
  • Occupation:Art Director

Posted 14 September 2017 - 02:04 AM

I see 3 different brands offered on Rock Auto, which one did you guys choose? By the way, my sending unit does not have a second return line tube, I will need the single line unit.

 

Chris, below is a screenshot of my order (I previously said "without" return line but it's "WITH" return line)  : 

Attached File  screenshot_46.jpg   53.57KB   0 downloads


Romain

Posted Image
Work Hard, Make Money, Fix your Car !

#24 NWmonte71

NWmonte71

    Advanced Member

  • Members

  • 87 posts
  • LocationPoulsbo, WA
  • Legal Name:Chris Harris
  • Occupation:DON

Posted 17 September 2017 - 01:20 PM

Chris, below is a screenshot of my order (I previously said "without" return line but it's "WITH" return line)  : 

attachicon.gifscreenshot_46.jpg

Cool. Thank you, sir!  It looks like you ordered the Spectra brand unit. 


sml_gallery_5838_288_247210.jpg1971 Monte Carlo, #'s matching 350cid with TH350, Factory "Lime Green" with original "Antique White" painted top.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Home Page
Mission|Benefits|Join|Renew|Merchandise
Message Forum
Members' Montes|Meet Photos
Tech Info|Museum|Parts|Registry|Links|Contact Us