Message Board

 
 

2018 Western Meet
[clock1]

2018 Eastern Meet
[clock2]
 
 
Home  | Join  | Merchandise  | West Meet | East Meet | Monte photos
Meet Photos | Tech  | Museum  | Parts  | Registry  | Links  | Officers
 
 

Jump to content


Photo

MSD - HEI coil or Module going bad?


  • Please log in to reply
3 replies to this topic

#1 snomobeelr

snomobeelr

    Bronze Member

  • Members

  • 591 posts
  • LocationMount Prospect,Il

Posted 09 July 2017 - 09:17 AM

Went to start car to go to cruise night and had no spark. MSD Pro-Billet HEI Distributors 8365. 

Pulled cap verified rotor turning checked connections and reinstalled. Had spark for about two minuntes and then nothing again. Had old HEI coil and started up and ran fine. Made it about 20 Miles and started poping through the exhaust. Very slightly at 1st and went away when I placed it in neutral. Started getting worse with popping made it to car show idling through parking lot and it was poping.

 Checked out the car show about an hour and a half later came back to car. Checked connections. Started fine and made a run for home. about 4 miles from home she poped a couple times and stopped popping , had a straight run at about 50 MPH for 5 min no poping just kept it steady. Made it to our street and right as I was about to pull in my son says good thing she didn't blow up and die. Well she didn't blow but she died right after he said that. Not enough to even make it up the driveway. Darn Kid's.   :rofl:

  Went out a couple hours later she fired her up and in the garage. Just for giggles I put the original could in they morning and she fired up? Looked up testing coils and not much there but after that Im thinking it the Module? 



#2 502ci

502ci

    MODERATOR in the 11's

  • Moderators

  • 15,345 posts
  • LocationRichfield, Ohio
  • Legal Name:Bill
  • Occupation:Union Electrician / Local 38/Commercial, Industrial

Posted 09 July 2017 - 10:09 AM

Are you running an MSD ignition box...6A, 6AL, 6AL2, etc?

 

Not the same symptoms as yours but my old MSD 6AL would cut the motor off after say 3 minutes and would not not let it restart for a short period of time, then it would fire right back up and run perfect, and then shut back off after the 3 minute mark.


Bill
us_flag.gif
MolĂ´n Labe
IMG_0120%20Custom%203_zpslviyc3dc.jpg
11.80's at 114 mph, 0-60 in 3.34 sec.____
Click here to see my never ending project
__________Click here to hear it__________
 


#3 snomobeelr

snomobeelr

    Bronze Member

  • Members

  • 591 posts
  • LocationMount Prospect,Il

Posted 09 July 2017 - 10:15 AM

No Box, Just the Distributor whiz is about 3 years old and just under 3000 miles on it. 



#4 snomobeelr

snomobeelr

    Bronze Member

  • Members

  • 591 posts
  • LocationMount Prospect,Il

Posted 14 July 2017 - 08:53 AM

Loose Cable ??   Another issue I had was when the car was Cold the starter would just click and on the 5th attempt it would turn over and start. This didn't happen when hot just when cold.and had been happening for a while. This was happening prior to the issue I thought was the Coil or the Module. 

   While trying to figure out how to test the Coil or the Module I was also going over the connections. Last thing I checked and expected was the Positive Cable to the battery connection. I have the Side Post terminal and the connection from the cable to the terminal is a Clamp. See attached Picture. One of the Bolts clamping the cable was so loose I could turn it freely with my fingers. The other bolt was not that loose but loose enough it needed to be Tightened.

   Since I have tightened up the connections I have not had the starter issue. I am wondering if this is the issue with no spark ? Not a good connection to battery and voltage drop, or would alternator take care of that? And my stock tachometer just went out again but the Auto-meter Tachometer is  still working. Is it a Myth that a tachometer with issues can cause issues with the HEI ?

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Home Page
Mission|Benefits|Join|Renew|Merchandise
Message Forum
Members' Montes|Meet Photos
Tech Info|Museum|Parts|Registry|Links|Contact Us