Jump to content

What did you do to your Monte Carlo today?


Recommended Posts

Didn't get the exhaust clamps today, what a fiasco but i'll save that rant for some other time lol. I did get the LED tail lights installed today, very impressed! Ive included the link/thread below, the pig tail made it plug and play, same thing if you wanted to go back. 

 

 

Link to post
Share on other sites
  • Replies 2.4k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Well I finally got the radiator show panel I won at the eastern meet put on the car. I've had it for over a month now but have been away on vacation.  Here it is

I got it all back together. Just need to fill up with coolant and fire it up. Then I’ll find out where all my oil leaks are. LOL

Got a little monte time in today, put almost 50 miles on. Went to see my daughter and grand kids and my girl and her grand kids. Was a nice day.

Posted Images

Applied high build primer 3 weeks ago, put parts back in - drove it last Saturday for first time in a year!  Switched driver with my son, it died on us,  My wife came to rescue us by giving it a jump start, had difficulty keep it running, back in garage 😪

B69FC11B-7990-4D3D-8D6E-8AA5E5F9DC94.jpeg

Link to post
Share on other sites

I feel your pain , I don’t know how many times in my life that I’ve been there, now 66 and still have the same problem just not with my monte 

Link to post
Share on other sites

Hope those in Carlisle are enjoying themselves and no more traveling issues, waiting on more pics lol. Got the exhaust clamps today and made my first voyage onto the main roads. Monte wasn't running right, thought I had 2 spark plug wires crossed but no. Insert advertisement for HF digital hand held temp gauge. Had one loose wire on the dizzy and spark plug 1 was off the spark plug (not obvious) so after that it was game on lol. Still needs some tweaking but I went through a 1/4 tank of gas in just the few test runs down the main road so I wasn't being light on the pedal laughing. Not that I didn't enjoy/appreciate the time  it took me to get to this point but its so satisfying to have the Monte back on the road again 

Link to post
Share on other sites

Removed all 4 rotors to be turned to remove surface rust. Deglazed pads. Rebuilt Edelbrock while rotors were being turned. Got the new vacuum boost and master cylinder to install next week. Finally running after setting for about 3 years! WOOOO!!!!HOOOOO!!!!!!

Link to post
Share on other sites

Glad everyone had fun at the meet! I'm aiming for next year I guess! Still plugging away!  Got some rot holes on inner door patched up, as well as rear window area pieces. Just got to pretty them up, and I should be able to get ready for epoxy tomorrow! 

15937336748963643515504698489943.jpg

15937336450644793590074154529091.jpg

20200702_183128.jpg

20200702_183100.jpg

20200702_171046.jpg

20200702_171027.jpg

Link to post
Share on other sites

Well I washed the Monte yesterday, I waited till 4pm so it was only 93 degrees out lol. And in typical south florida weather it started raining as soon as I pulled the Monte back in the garage, and yes the sun was still shinning. Planned on going on a little cruise this evening but the real clouds with thunder and rain rolled in so nix'd that plan. Hopefully the weather is better tomorrow so I can start logging more break in miles, need to do some detailing too. No sense cruising around with a first gen not in all its beautiful glory. Either way i'm going to re-install the grill tomorrow, while I originally enjoyed the "mean" look i'm seeing it now more as an "unfinished" look and its not sitting well with me. Happy 4th everyone

Link to post
Share on other sites

Went for a nice drive and put on 52 miles. It's now getting too hot (see the sun!!) 1543479849_1971MonteCarlo01.JPG.cc27a79d8609b89abc9b365c8dd0b7fd.JPG

so I'm home, writing about it. Here is a picture, I love pictures...

Link to post
Share on other sites

Stayed pretty busy over the holiday weekend. Got rear window patches in, stripped rest of the car. Treated and neutralized everything. Primered inside of doors, jambs, window channels. New deck filler panel installed,  then I got trained out.. so full primer coat will have to wait. 

received_316499716050087.jpeg

received_279851686601871.jpeg

received_605513703435368.jpeg

20200706_192330.jpg

Link to post
Share on other sites

As I have a fiberglass hood, I've been debating how to mount windshield squirters. The idea came to me that many vehicles today have squirters on the wiper blades.

I found these on Ebay from a 97~01 Jeep Cherokee rear wiper. They snap on the Monte arms nicely. I think a drop of super glue will make sure they stay snapped.

squirters 1.jpg

squirters 2.jpg

Link to post
Share on other sites

So I had to order a new driveshaft, custom built this time so while I’m waiting decided to tackle the gas gauge issue. New send unit with AN8 fittings this time around. A work of art 😊

3E1E79C4-23AC-4FE9-9324-50E44E8AA1CE.jpeg

82BCA9C9-A10A-45A4-B3F0-1C622BFB844B.jpeg

4228F025-5F51-4F25-88B3-DFEED2A7F208.jpeg

F7288211-097E-4467-80B4-64C13158FE27.jpeg

84559A4D-2F60-46FC-A34D-6878D5A2AB5E.jpeg

Link to post
Share on other sites

I had some leaking seals on the rear end after sitting for a couple of years. Replaced the pinion seal, and both axle seals. When I pulled the left axle there was some pitting marks in the bearing area, so I decided it was time for new axles and bearings. Got the new stuff at Summit. It’s sure nice to have that close by. Got it all buttoned up and will add fluid tomorrow before it gets to hot. It was about 96 degrees when I called it for the day.

Link to post
Share on other sites

Decided to start a project today. Pulled all the accessories of the 70 Monte engine. Scraped loose paint off and degreased it. More scraping and degreasing tomorrow. I also want to get the exhaust manifolds powder coated which will get rid of the only rusty thing that was left in my engine bay. The last time I did this extensive of a paint job on this engine was 1997 when I was 20.... I want my 20 year old body back...LOL

D4E47382-0D5B-45ED-B00F-02D637E5C4C9.jpeg

65EAA300-46E1-418E-B0B1-A28D4F4A2635.jpeg

D61A0F62-AEC6-4FB3-8B5D-6DECCB48A02A.jpeg

Link to post
Share on other sites

  I want my 20 year old body back...LOL 

Well you can't have it back unless I get mine back too but I will settler for my 40 year old body

 

Link to post
Share on other sites
21 minutes ago, Paul Bell said:

With all that stuff removed and the exhaust manifolds coming off, ya might as well spend another 30 minutes and yank the engine.

I’m trying to avoid the snowball effect... haha

Link to post
Share on other sites
1 hour ago, cny first gen 71 said:

Aren't you supposed to start a project like this in the winter? Oh wait you have 2 montes to drive :rofl: looks good so far

Yep, I can still cruise in the 71. :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...