Jump to content
Sign in to follow this  
Mfoge5

Am I on the right track?? Brake Light issue..

Recommended Posts

Ok recently was told by someone who followed me home I didnt have any brake lights.  Everything else seemed fineI had been putting it off until recently when I came across a set of LED tail lights.  I install the LEDs and there is LIGHT!! these things are bright !!! all except for my drivers side brake and blinker... Tail light works .. all passenger and front lights work.  I am getting power to the orange wire at the brake switch.  Should I be getting power to both??? from what I have read the drivers side brake and blinker go through the directional switch in the column .. Correct??? so thats most likely the culprit ??? not the brake light switch... Or is it a ground?? if it could be can someone let mne know where they all are i should check.  Basically my question is Am I on the right track ??? I know you guys have answered this exact question already but everyone has their own little special circumstance I guess.  But thanks in advance It is truly appreciated...

Share this post


Link to post
Share on other sites

The brake switch should have power going in on one side believe it’s an orange wire. When the brake paddle is push power carries over to the other wire which runs to the tail lights. Did you change the flashers to a digital flasher? The fact that the passenger side is bright while the drivers side is dim doesn’t make sense as the passenger side gets its power feed from the drivers side brake light.

Share this post


Link to post
Share on other sites

Ok still playing around with it and I have to edit what is working and whats not... tail lights work when I pull the headlight switch and when I said they were bright I am seeming to think thats bcuz the brake lamps are illuminated.  if i hit the pedal the passeger side will blink twice and then dim.  I took the steering wheel off to change the turn signal switch and began playing around with the old switch and am beginning to think it may be as ground issue.  Ive been finding things a bit corroded after this rain and things were leaked on I see nowis there something that shows the ground locations??? I know that I had some ground issues with my corvette and they caused all sorts of weird and unhelpful failures of different components in the car.. I know that the c4 is way more electrical than the 70 MC butI now realize grounds are grounds no matter how elaborate and they are critical to things working right ...I will post any other details as I probe the column and dash..

Share this post


Link to post
Share on other sites

You're on the right track searching for ground problems, especially when lighting issues like you're having occur.

Share this post


Link to post
Share on other sites

Thanks I think I got it..  I checked and tightened any grounds I saw under the dash the door jamb switch headlight switch.. Found that my passenger side front marker bulkb was out and replaced it.. Then replaced the turn signal switch.  Ill just say it was this combo thatwas needed..  Those LED lights are 100-150% better than incandescent.  thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...